Abr
21
2012
0

Configuración básica de hogar para un Cisco AIR-AP1131-AG-E-K9

A continuación se muestra una pequeña configuracion de un punto de acceso Cisco AIR-AP1131-AG-E-K9 para una configuración básica casera.


version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname AIR-AP1131
!
logging rate-limit console 9
enable secret clave_enable
!
no aaa new-model
led display alternate
ip name-server 8.8.8.8
ip name-server 8.8.4.4
!
!
dot11 syslog
!
dot11 ssid MiSSID
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii miclavewpa
!
power inline negotiation prestandard source
!
!
username admin password clave_de_usuario_admin
!
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption mode ciphers aes-ccm
!
ssid MiSSID
!
channel 2452
station-role root
no dot11 extension aironet
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio1
no ip address
no ip route-cache
shutdown
no dfs band block
channel dfs
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
hold-queue 160 in
!
interface BVI1
ip address 192.168.1.254 255.255.255.0
no ip route-cache
!
ip default-gateway 192.168.1.1
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
logging 10.0.0.1
snmp-server community public RO
snmp-server ifindex persist
snmp-server location Ubicacion
snmp-server contact Contacto
bridge 1 route ip
!
!
line con 0
line vty 0 4
login local
!
sntp server 150.214.94.5
sntp broadcast client
end

 

Written by Javier Rodriguez in: Cisco,Redes |
Ene
15
2011
6

VLANs dinamicas en Cisco



Una opción interesante cuando tenemos una red grande que gestionar, con varias VLANs y queremos disponer de movilidad, son las VLANs dinámicas que nos ofrecen los Switches y Routers de CISCO. Si disponemos de un Router de Cisco que permita hacer de Servidor VMPS podemos saltarnos el primer paso, pero debéis buscar en alguna otra página web como configurarlo.

En este caso vamos a utilizar un servidor Linux con Debian Lenny como servidor VMPS. Desde la página web del proyecto OpenVMPS bajamos la última versión estable del paquete. Lo compilamos y lo instalamos.

La instalación por defecto se queda de la siguiente forma:

  • Binario: /usr/local/bin/vmpsd
  • Configuracion: /usr/local/etc/vlan.db

Debemos ejecutar el binario en segundo plano o prepararnos un script de arranque y parada, de tal manera que cada vez que hagamos un cambio en el archivo de configuración podamos reiniciar el servicio facilmente.

El archivo de configuración de VLAN lo deberemos dejar de la siguiente forma:


vmps domain MiDominio
vmps mode secure
vmps fallback VLAN_fallback
vmps no-domain-req allow


!
!MAC Addresses
!
vmps-mac-addrs
address 000c.1234.0001 vlan-name VLAN_nombre1
address 000c.1234.0002 vlan-name VLAN_nombre2

Como veis, especificamos un nombre de dominio MiDominio y las VLANs están escritas con nombre y no de forma numérica. Esta la opcion de fallback, que sirve para que cuando una MAC no esta en la lista de direcciones MAC la mete en esa VLAN predeterminadamente.

Ahora nos toca configurar el Switch. Nos metemos en modo privilegiado y ejecutamos los siguientes comandos:

configure terminal
vmps server 192.168.34.10 primary
vtp domain MiDominio
end

La dirección IP 192.168.34.10 es la IP del servidor Linux donde tenemos ejecutándose el vmpsd y al cual, deberemos tener acceso desde el switch, obviamente.

Y después configuramos la boca. Hay que sacarla de la VLAN en la que este antes de ponerla que es VLAN dinámica.

configure terminal
interface fastethernet 0/xx
no switchport port-security mac-address xxxx.xxxx.xxxx
no switchport access vlan xxx
switchport access vlan dynamic
end

Esto con todas las bocas que queramos. Cuando acabemos de configurar las bocas escribimos:

vmps reconfirm

Y con estos simples pasos ya tenemos VLANs dinámicas en nuestra red.

Written by Javier Rodriguez in: Cisco,Redes | Etiquetas: , ,

Theme: TheBuckmaker.com Blog Themes | Hostpapa customer, Berlin